find what you are looking for or ask a new question
Home > Forum > Data sources

Data sources

hello, I need to migrate local groups from production to dev environment, do you know database table or do you have sql that will show me all local grups, even empty one ? thanks in advance.

Hi, how to set a filter in the data source for a data table so that search-filtering by date works. The usual filtering according to the scheme does not work: 1. "some date (iso or browser settings)" = "field in the data table with a date" (like attachment) 2. "some date (iso or browser settings)" like "field in the data table with a date"

Hi everyone, I tried to connect to one of our sharepoint online sites. For some reason, I get a message that the login or username is not correct. (see screenshot) If I use the same login data for our on-prem Sharepoint 2013, it works fine. (see screenshot) On the Sharepoint online site which I want to connect, I am logged in with my valid credentials and I am both in the member and the owner group. (see screenshots) Our on-prem AD is fully synchronised with MS Entra ID (formerly Azur (...)

Hi, Sorry for my lack of knowledge but I've just installed WEBCON 2 days ago. Please help! I want to add in a item list rows from a SQL database but: Querying data is ok. I want to select a product name based on that query (from a Choice field) and get the correspondent price from the query... Also my query is based on another field as a filter When I change the value of that filter, the list of products should change but it doesn't. And also, I can't get the price for the product... (...)

Hello, Does anyone has a rest api configured to access Sales Force? I have a connection and I use it in a process but I'm getting the data from Opportunities. I would like to bring in a specific report. I've checked how to do this and I came up with this query using the GET /services/data/v52.0/analytics/reportTypes/Opportunity But when I use the field as a Data table in order to check the information, the list comes empty. Anyone tried this? Do you know how to bring reports instead of (...)


Hi, We have an issue related to the usage of columns from a datasource (dictionary, BPS internal view) within a choicefield-type field. The user 'windows user' has created a new application, a new process, and a new dictionary. After configuring these, the user created the corresponding datasources for them. They created a new process where they associated the dictionary/process with choicefield-type fields. For data filtering, they used the fields from the datasources as filters. An (...)

Hello everyone, I need your help with a task that should actually be relatively simple. I'm trying to establish a connection to my Site Collection in SharePoint and have entered the relevant data (Server and Site Collection, User, ...). When I click on "test", it loads for several seconds, and I get the error: Unable to connect to the remote server. Regarding my rights in SharePoint: I am the owner of the Site Collection. What could be the cause of this? Thanks in advance!

Hello. Has anybody an idea if and how it is possible to create a data source from two different data connections? I.e. I have a database (MS SQL) with visitor data and the CacheOrganizationStructure table in the webcon content DB (MS SQL, too). Now I want to create a datasource for a Choice field, where I could query for names in both tables. It is purely for reading data. Kind regards Klaus

Hello all, Does anyone knows or have configured something that can relate the country vs national holidays in the country? Like having the calendars for Portugal Holidays, Spain, etc I know that we have to manually insert the holidays in the System configuration for calendar's table but in this case, the idea is, if I'm abroad and inserting extra hours, by defining where I am, the system could check if it's an holiday or not. Thanks!

Hello all, Does anyone configured an action where the value in a specific column for an item list is a value coming from a datasource different than MS sql server? My idea is, I need to get from an oracle table the rate for a specific employee, so I'm using the action with Datasource = my table and in the advanced filter, I just add the person id and the dates for comparison but this is not working. I've added a screenshot. If I use the field manually, I'm able to get that specific lin (...)

How can I initialize attachments on the item list in the subworkflow? The initializing query retrieves text fields, but does not retrieve attachments. I receive an error message: Validation Error, SubElems (ID: 9031) Attachment not found. SubElems (ID: 9031) Attachment not found.

Working on a project whereby there is a process to track delinquent loans and create collection activities based on ageing. We receive loan data as a daily dump in excel and new or modified rows should either fire new instances of our workflows or trigger certain paths in existing workflows.Unsure of how to go about this

Hello, in the "Absences" application I have two processes: Employee file, Holiday request. I wanted to ask you, how do you organize data sources for such a process? 1. Should the source of data be an employee's file with a list of items that reflects holiday leave limits? In this case, each submitted application should update the parent workflow (Employee file), but I am afraid that over time the file will have too many versions. On the other hand, I have change history and actual data. (...)


Hi everyone, does anyone has an idea, why a data source dictionary would not return all data, also "access data in the context of system account" is checked? I was banking my head on the wall, why the form validation stopped working until I noticed that the lastest workflow instances are not returned by the data source. The screenshot shows the data from the "data sources" navigation pane, it's not a field which is filtered. Best regards, Daniel

Dear Community, I just discovered that when I select SearchIndex as a source for calendar type report, elements are in different timezone than server time. When I change source to SQL source everything is fine. Does anyone experience same issue? Best.

After upgrade to version 2022.1.4.174 I get errors on some querries that use <Current BPS Connection>. Error occurs when querying another database directly or using join, etc from SQL COMMAND or choose field querry. I found that this is related to change described in https://community.webcon.com/download/changelog/117?q=cf05b90, associated with using bps_user on SQL COMMANDS. Is there any way to deal with it at SQL server level by proper configuration or should I change <Current BPS Connecti (...)


Hello, is there a possibility to use existing SOLR as Data Source? I had an idea to show users SQL grid, which would show similar items found in database, based on text typed in regular TextInput field. That lead me to Levenshtein Distance algorithm, which might be slow in SQL, but i've found that such a thing is already implemented in SOLR (https://stackoverflow.com/questions/1752301/how-to-configure-solr-to-use-levenshtein-approximate-string-matching). Also, any ideas how to implement i (...)

I am attempting to control the AD sync on two different domains. How do I filter out the disabled accounts on the domains? There are users with the same names on both domains, is it possible to have the unique identifier the BPS ID as opposed to the Name so that users with the same name can by synced as 2 different accounts?

Dear Forum I am trying to remove SharePoint list items in one of actions. It works well when I pass a sharepoint item ID, but I do not have this available in webcon. I would like to delete an item based on other column that I have. I tried CAML query below, but it does not work. Tried different columns, tried "" and '', tried contains but it does not work. Any ideas how to do it properly? <Where> <Eq> <FieldRef Name="Project Code"/> <Value Type="Text">3153</Va (...)

Hi, After updating BPS to version 2022.1.4.111, I can't see the data source columns for dictionary processes. This applies to creating filters. Fixed value lists do not have this problem. What is causing this problem or change in behavior?